Many licensed and some free of cost script-driven apps have protected program code, which isn't human readable. The reasoning behind this is to avoid the reverse engineering and the illegal usage of such applications. One of the most popular encryption instruments used for this purpose is called Zend Guard and it is very popular since it can be used to modify any PHP 4 or PHP 5 code. The only way for the protected files to work efficiently on a web server subsequently is if an extra instrument called Zend Optimizer is there. In the event that you wish to employ any kind of paid web software which needs Zend Optimizer, you should ensure that it's installed on the server where you'll host your website. In addition, websites that require the instrument can perform better due to the fact that their code is already precompiled and optimized, meaning that it is executed faster.

Zend Optimizer in Cloud Hosting

Zend Optimizer is present on our in-house made cloud platform and you're able to use it whatever the cloud hosting plan that you select. It can be enabled from the Hepsia Control Panel which is provided with all the accounts and it'll take you as little as a couple of clicks to do this. Considering that we support several different releases of PHP (4, 5.2, 5.3, 5.4, 5.5), you will have to enable Zend Optimizer every time you switch the version to one you have not used yet. This is very easy though - the php.ini file where you can enable and disable various PHP extensions can be managed with a point-and-click tool, and you do not need any kind of computer programming skills or previous experience. Our website hosting services will allow you to run any script-driven app that requires Zend Optimizer without difficulties, but if you are unsure what you should do, you'll be able to contact our 24/7 tech support team and they will activate the tool for you.